summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2006-10-02 15:20:37 (GMT)
committerMartin v. Löwis <martin@v.loewis.de>2006-10-02 15:20:37 (GMT)
commit40e9aed050e4fac881487fcfb125306fce0431d9 (patch)
treeaa333d9cdc5f481a1f607043e11f9a5c4ddfcc22 /configure.in
parentebe26709d2c5c6b633071acc9565ca6116cd0a55 (diff)
downloadcpython-40e9aed050e4fac881487fcfb125306fce0431d9.zip
cpython-40e9aed050e4fac881487fcfb125306fce0431d9.tar.gz
cpython-40e9aed050e4fac881487fcfb125306fce0431d9.tar.bz2
Guard uintptr_t test with HAVE_STDINT_H, test for
stdint.h. Will backport.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 6fd8fdf..af95a2e 100644
--- a/configure.in
+++ b/configure.in
@@ -1068,8 +1068,8 @@ dnl AC_MSG_RESULT($cpp_type)
AC_HEADER_STDC
AC_CHECK_HEADERS(asm/types.h conio.h curses.h direct.h dlfcn.h errno.h \
fcntl.h grp.h \
-shadow.h io.h langinfo.h libintl.h ncurses.h poll.h process.h pthread.h \
-signal.h stropts.h termios.h thread.h \
+io.h langinfo.h libintl.h ncurses.h poll.h process.h pthread.h \
+shadow.h signal.h stdint.h stropts.h termios.h thread.h \
unistd.h utime.h \
sys/audioio.h sys/bsdtty.h sys/file.h sys/loadavg.h sys/lock.h sys/mkdev.h \
sys/modem.h \
@@ -1199,7 +1199,9 @@ fi
AC_CHECK_TYPES(uintptr_t,
[AC_CHECK_SIZEOF(uintptr_t, 4)],
- [], [#include <stdint.h>])
+ [], [#ifdef HAVE_STDINT_H
+ #include <stdint.h>
+ #endif])
# Hmph. AC_CHECK_SIZEOF() doesn't include <sys/types.h>.