summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>1997-08-21 00:08:11 (GMT)
committerGuido van Rossum <guido@python.org>1997-08-21 00:08:11 (GMT)
commit8456161fcd155b0c60f9bdeaa0e706ad9f54b0c8 (patch)
tree9b41793995df2b85813ad11461ba4bebfac8fa11 /configure.in
parent1bf0bf40b48d4cae7341c47322e0cbe2bf0b2ae8 (diff)
downloadcpython-8456161fcd155b0c60f9bdeaa0e706ad9f54b0c8.zip
cpython-8456161fcd155b0c60f9bdeaa0e706ad9f54b0c8.tar.gz
cpython-8456161fcd155b0c60f9bdeaa0e706ad9f54b0c8.tar.bz2
Richard Jones: I think we can be confident in using 'CC="-Aa
-D_HPUX_SOURCE"' on HP 9.x and 10.x platforms.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 10545dc..5e6e876 100644
--- a/configure.in
+++ b/configure.in
@@ -82,6 +82,13 @@ fi
AC_PROG_CC
+case $ac_sys_system in
+hp*|HP*)
+ case $CC in
+ cc|*/cc) CC="$CC -Aa -D_HPUX_SOURCE";;
+ esac;;
+esac
+
# LINKCC is the command that links the python executable -- default is $(CC).
# This is altered for AIX in order to build the export list before linking.
AC_SUBST(LINKCC)