summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAntoine Pitrou <solipsis@pitrou.net>2010-09-10 20:03:17 (GMT)
committerAntoine Pitrou <solipsis@pitrou.net>2010-09-10 20:03:17 (GMT)
commitaabdceba515d7f43f378c0aba897d1e697e416c8 (patch)
treed9bbb3c759e30ba07d3e6c7cebf445ca19a4737b /configure.in
parentb170f17bacf77996667b8814ed4f0940409b1810 (diff)
downloadcpython-aabdceba515d7f43f378c0aba897d1e697e416c8.zip
cpython-aabdceba515d7f43f378c0aba897d1e697e416c8.tar.gz
cpython-aabdceba515d7f43f378c0aba897d1e697e416c8.tar.bz2
Merged revisions 84680 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/branches/py3k ........ r84680 | antoine.pitrou | 2010-09-10 21:44:44 +0200 (ven., 10 sept. 2010) | 4 lines Issue #941346: Improve the build process under AIX and allow Python to be built as a shared library. Patch by Sébastien Sablé. ........
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 2c0bf4f..51cdaa5 100644
--- a/configure.in
+++ b/configure.in
@@ -823,6 +823,10 @@ if test $enable_shared = "yes"; then
BLDLIBRARY='-L. -lpython$(VERSION)'
RUNSHARED='DYLD_LIBRARY_PATH=`pwd`:${DYLD_LIBRARY_PATH}'
;;
+ AIX*)
+ LDLIBRARY='libpython$(VERSION).so'
+ RUNSHARED=LIBPATH=`pwd`:${LIBPATH}
+ ;;
esac
else # shared is disabled
@@ -1757,7 +1761,7 @@ if test -z "$LDSHARED"
then
case $ac_sys_system/$ac_sys_release in
AIX*)
- BLDSHARED="\$(srcdir)/Modules/ld_so_aix \$(CC) -bI:Modules/python.exp"
+ BLDSHARED="\$(srcdir)/Modules/ld_so_aix \$(CC) -bI:Modules/python.exp -L\$(srcdir)"
LDSHARED="\$(BINLIBDEST)/config/ld_so_aix \$(CC) -bI:\$(BINLIBDEST)/config/python.exp"
;;
BeOS*)
@@ -4273,6 +4277,7 @@ AC_MSG_RESULT(done)
# generate output files
AC_CONFIG_FILES(Makefile.pre Modules/Setup.config Misc/python.pc)
+AC_CONFIG_FILES([Modules/ld_so_aix], [chmod +x Modules/ld_so_aix])
AC_OUTPUT
echo "creating Modules/Setup"