summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMark Dickinson <dickinsm@gmail.com>2009-12-31 21:20:06 (GMT)
committerMark Dickinson <dickinsm@gmail.com>2009-12-31 21:20:06 (GMT)
commitcaa44c057ace6a3b36119b62ddb1bd24427e4f85 (patch)
treefcd6015f79b8a2a32a8529d637ce6c1cb3a8302d /configure.in
parentd19e14347e08bc17dcc00458e66b6c7f8de10893 (diff)
downloadcpython-caa44c057ace6a3b36119b62ddb1bd24427e4f85.zip
cpython-caa44c057ace6a3b36119b62ddb1bd24427e4f85.tar.gz
cpython-caa44c057ace6a3b36119b62ddb1bd24427e4f85.tar.bz2
Merged revisions 77193 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk ........ r77193 | mark.dickinson | 2009-12-31 21:11:48 +0000 (Thu, 31 Dec 2009) | 1 line More configure fixes: avoid sh 'integer argument expected' error when 'long long' type doesn't exist. ........
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 42af0f8..6b9d00c 100644
--- a/configure.in
+++ b/configure.in
@@ -1448,8 +1448,9 @@ AC_DEFINE_UNQUOTED(SIZEOF_OFF_T, $ac_cv_sizeof_off_t,
[The number of bytes in an off_t.])
AC_MSG_CHECKING(whether to enable large file support)
-if test "$have_long_long" = yes -a \
- "$ac_cv_sizeof_off_t" -gt "$ac_cv_sizeof_long" -a \
+if test "$have_long_long" = yes
+then
+if test "$ac_cv_sizeof_off_t" -gt "$ac_cv_sizeof_long" -a \
"$ac_cv_sizeof_long_long" -ge "$ac_cv_sizeof_off_t"; then
AC_DEFINE(HAVE_LARGEFILE_SUPPORT, 1,
[Defined to enable large file support when an off_t is bigger than a long
@@ -1460,6 +1461,9 @@ if test "$have_long_long" = yes -a \
else
AC_MSG_RESULT(no)
fi
+else
+ AC_MSG_RESULT(no)
+fi
# AC_CHECK_SIZEOF() doesn't include <time.h>.
AC_MSG_CHECKING(size of time_t)