summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2010-03-09 21:46:54 (GMT)
committerBenjamin Peterson <benjamin@python.org>2010-03-09 21:46:54 (GMT)
commite9e07bf5c988bdfe4158d3ac14b25312430f1bd0 (patch)
tree9b672d94cba175348d71dab2b36c33f6422aabeb /configure.in
parent3281067e0914637d9ca68056cb9ce657d67d0f06 (diff)
downloadcpython-e9e07bf5c988bdfe4158d3ac14b25312430f1bd0.zip
cpython-e9e07bf5c988bdfe4158d3ac14b25312430f1bd0.tar.gz
cpython-e9e07bf5c988bdfe4158d3ac14b25312430f1bd0.tar.bz2
fix ugly configure output (follow up to #6943)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 5491778..0fadd75 100644
--- a/configure.in
+++ b/configure.in
@@ -2039,6 +2039,8 @@ LIBS="$withval $LIBS"
],
[AC_MSG_RESULT(no)])
+AC_PATH_TOOL([PKG_CONFIG], [pkg-config])
+
# Check for use of the system expat library
AC_MSG_CHECKING(for --with-system-expat)
AC_ARG_WITH(system_expat,
@@ -2051,8 +2053,7 @@ AC_MSG_CHECKING(for --with-system-ffi)
AC_ARG_WITH(system_ffi,
AC_HELP_STRING(--with-system-ffi, build _ctypes module using an installed ffi library))
-if test "$with_system_ffi" = "yes"; then
- AC_PATH_TOOL([PKG_CONFIG], [pkg-config])
+if test "$with_system_ffi" = "yes" && test -n "$PKG_CONFIG"; then
LIBFFI_INCLUDEDIR="`"$PKG_CONFIG" libffi --cflags-only-I 2>/dev/null | sed -e 's/^-I//;s/ *$//'`"
else
LIBFFI_INCLUDEDIR=""