summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorSkip Montanaro <skip@pobox.com>2004-08-15 14:08:23 (GMT)
committerSkip Montanaro <skip@pobox.com>2004-08-15 14:08:23 (GMT)
commitf0d5f7917e4c6b4acd209573c8f69c3dc5793ffd (patch)
treeae147eb798c1801a287ac304e7581e44bcf441f5 /configure.in
parent8d3b9dd09c650554445271c6774299c0ae669f83 (diff)
downloadcpython-f0d5f7917e4c6b4acd209573c8f69c3dc5793ffd.zip
cpython-f0d5f7917e4c6b4acd209573c8f69c3dc5793ffd.tar.gz
cpython-f0d5f7917e4c6b4acd209573c8f69c3dc5793ffd.tar.bz2
Match the def'n of _XOPEN_SOURCE on Solaris 8/9 to suppress redefinition
warning from GCC. Closes patch #1006629.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 6f99ae9..f0a1bda 100644
--- a/configure.in
+++ b/configure.in
@@ -170,8 +170,18 @@ esac
if test $define_xopen_source = yes
then
- AC_DEFINE(_XOPEN_SOURCE, 600,
- Define to the level of X/Open that your system supports)
+ # On Solaris w/ g++ it appears that _XOPEN_SOURCE has to be
+ # defined precisely as g++ defines it
+ case $ac_sys_system/$ac_sys_release in
+ SunOS/5.8|SunOS/5.9)
+ AC_DEFINE(_XOPEN_SOURCE, 500,
+ Define to the level of X/Open that your system supports)
+ ;;
+ *)
+ AC_DEFINE(_XOPEN_SOURCE, 600,
+ Define to the level of X/Open that your system supports)
+ ;;
+ esac
# On Tru64 Unix 4.0F, defining _XOPEN_SOURCE also requires
# definition of _XOPEN_SOURCE_EXTENDED and _POSIX_C_SOURCE, or else