summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMark Dickinson <dickinsm@gmail.com>2008-05-23 04:22:50 (GMT)
committerMark Dickinson <dickinsm@gmail.com>2008-05-23 04:22:50 (GMT)
commit8f66a4a3dbae9fca8a0963892928dc3cda3f1aef (patch)
treeceb3c5ec08d732cb0930bfa7c3314337818a88f5 /configure.in
parentd05583525397a3e86885436f0e71d6995c608e43 (diff)
downloadcpython-8f66a4a3dbae9fca8a0963892928dc3cda3f1aef.zip
cpython-8f66a4a3dbae9fca8a0963892928dc3cda3f1aef.tar.gz
cpython-8f66a4a3dbae9fca8a0963892928dc3cda3f1aef.tar.bz2
Temporary checkin to get configure to report more
information about the processor on the Debian/alpha buildbot. (I'm still trying to track down the cause of the test_math failures for this machine.) This checkin will be reverted within the next 48 hours.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index bc9a02e..a7c96f9 100644
--- a/configure.in
+++ b/configure.in
@@ -350,6 +350,17 @@ AC_MSG_CHECKING(machine type as reported by uname -m)
ac_sys_machine=`uname -m`
AC_MSG_RESULT($ac_sys_machine)
+# temporary check to find out which exact processor
+# is in the Debian/alpha buildbot.
+case $ac_sys_system in
+ Linux*)
+ case $ac_sys_machine in alpha*)
+ cat /proc/cpuinfo
+ ;;
+ esac
+ ;;
+esac
+
# checks for alternative programs
# compiler flags are generated in two sets, BASECFLAGS and OPT. OPT is just