summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorChristian Heimes <christian@cheimes.de>2007-12-16 21:39:43 (GMT)
committerChristian Heimes <christian@cheimes.de>2007-12-16 21:39:43 (GMT)
commitdb3d6cbce00172e44a404fcb9570d011b4b70049 (patch)
tree89b60a58f3a6c93f443331f4b7c6cb5c5d70d3c4 /configure.in
parenteee1fc51ba1b4d184a8176c20d1d3a68bf837c97 (diff)
downloadcpython-db3d6cbce00172e44a404fcb9570d011b4b70049.zip
cpython-db3d6cbce00172e44a404fcb9570d011b4b70049.tar.gz
cpython-db3d6cbce00172e44a404fcb9570d011b4b70049.tar.bz2
Fixed #1638: %zd configure test fails on Linux
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 4964954..799499b 100644
--- a/configure.in
+++ b/configure.in
@@ -3459,9 +3459,9 @@ AC_TRY_RUN([#include <stdio.h>
#include <stddef.h>
#include <string.h>
-int main()
-{
- char buffer[256];
+#ifdef HAVE_SYS_TYPES_H
+#include <sys/types.h>
+#endif
#ifdef HAVE_SSIZE_T
typedef ssize_t Py_ssize_t;
@@ -3471,6 +3471,10 @@ typedef long Py_ssize_t;
typedef int Py_ssize_t;
#endif
+int main()
+{
+ char buffer[256];
+
if(sprintf(buffer, "%zd", (size_t)123) < 0)
return 1;