summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRonald Oussoren <ronaldoussoren@mac.com>2009-09-07 06:12:00 (GMT)
committerRonald Oussoren <ronaldoussoren@mac.com>2009-09-07 06:12:00 (GMT)
commit23d925311dafd2ec3885dfd158e7d3d10c9e08d0 (patch)
treefc3dfb43d148beeb3d52ffc0b44767edbbe29521 /configure.in
parent5515990ee1fbe48774dea9fe04d80385a1bf42f2 (diff)
downloadcpython-23d925311dafd2ec3885dfd158e7d3d10c9e08d0.zip
cpython-23d925311dafd2ec3885dfd158e7d3d10c9e08d0.tar.gz
cpython-23d925311dafd2ec3885dfd158e7d3d10c9e08d0.tar.bz2
Fix typo in configure.in
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 21 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 7b8f19d..ee95e8a 100644
--- a/configure.in
+++ b/configure.in
@@ -114,7 +114,7 @@ AC_SUBST(ARCH_RUN_32BIT)
UNIVERSAL_ARCHS="32-bit"
AC_MSG_CHECKING(for --with-universal-archs)
AC_ARG_WITH(universal-archs,
- AC_HELP_STRING(--with-universal-archs=ARCH, select architectures for universal build ("32-bit", "64-bit" or "all")),
+ AC_HELP_STRING(--with-universal-archs=ARCH, select architectures for universal build ("32-bit", "64-bit", "3-way", "intel" or "all")),
[
AC_MSG_RESULT($withval)
UNIVERSAL_ARCHS="$withval"
@@ -952,6 +952,14 @@ yes)
UNIVERSAL_ARCH_FLAGS="-arch i386 -arch ppc -arch ppc64 -arch x86_64"
ARCH_RUN_32BIT="arch -i386 -ppc"
+ elif test "$UNIVERSAL_ARCHS" = "intel" ; then
+ UNIVERSAL_ARCH_FLAGS="-arch i386 -arch x86_64"
+ ARCH_RUN_32BIT="arch -i386"
+
+ elif test "$UNIVERSAL_ARCHS" = "3-way" ; then
+ UNIVERSAL_ARCH_FLAGS="-arch i386 -arch ppc -arch x86_64"
+ ARCH_RUN_32BIT="arch -i386 -ppc"
+
else
AC_MSG_ERROR([proper usage is --with-universalarch=32-bit|64-bit|all])
@@ -977,6 +985,15 @@ yes)
# that's the first OS release where
# 4-way builds make sense.
cur_target='10.5'
+
+ elif test "${UNIVERSAL_ARCHS}" = "3-way"; then
+ cur_target='10.5'
+
+ elif test "${UNIVERSAL_ARCHS}" = "intel"; then
+ cur_target='10.5'
+
+ elif test "${UNIVERSAL_ARCHS}" = "64-bit"; then
+ cur_target='10.5'
fi
else
if test `arch` = "i386"; then
@@ -1539,7 +1556,7 @@ case $ac_sys_system/$ac_sys_release in
else
LIBTOOL_CRUFT=""
fi
- AC_TRY_RUN([[
+ AC_TRY_RUN([
#include <unistd.h>
int main(int argc, char*argv[])
{
@@ -1548,9 +1565,9 @@ case $ac_sys_system/$ac_sys_release in
} else {
return 1;
}
- ]], ac_osx_32bit=yes,
+ ], ac_osx_32bit=yes,
ac_osx_32bit=no,
- ac_osx_32bit=no)
+ ac_osx_32bit=yes)
if test "${ac_osx_32bit}" = "yes"; then
case `arch` in