summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorThomas Heller <theller@ctypes.org>2008-03-04 20:09:11 (GMT)
committerThomas Heller <theller@ctypes.org>2008-03-04 20:09:11 (GMT)
commit8bdf81d2df388ce06088193f95c992a7ee1eb553 (patch)
treed116a98944af811c3b5262d6318ddd1379bff8ff /configure.in
parent4a50d26ba229e5154b9c28c7e4073848f1850585 (diff)
downloadcpython-8bdf81d2df388ce06088193f95c992a7ee1eb553.zip
cpython-8bdf81d2df388ce06088193f95c992a7ee1eb553.tar.gz
cpython-8bdf81d2df388ce06088193f95c992a7ee1eb553.tar.bz2
Merged changes from libffi3-branch.
The bundled libffi copy is now in sync with the recently released libffi3.0.4 version, apart from some small changes to Modules/_ctypes/libffi/configure.ac. I gave up on using libffi3 files on os x. Instead, static configuration with files from pyobjc is used.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 0 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index bd16b2e..e731825 100644
--- a/configure.in
+++ b/configure.in
@@ -1754,20 +1754,10 @@ LIBS="$withval $LIBS"
[AC_MSG_RESULT(no)])
# Check for use of the system libffi library
-AC_CHECK_HEADER(ffi.h)
AC_MSG_CHECKING(for --with-system-ffi)
AC_ARG_WITH(system_ffi,
AC_HELP_STRING(--with-system-ffi, build _ctypes module using an installed ffi library))
-if test -z "$with_system_ffi" && test "$ac_cv_header_ffi_h" = yes; then
- case "$ac_sys_system/`uname -m`" in
- Linux/alpha*) with_system_ffi="yes"; CONFIG_ARGS="$CONFIG_ARGS --with-system-ffi";;
- Linux/arm*) with_system_ffi="yes"; CONFIG_ARGS="$CONFIG_ARGS --with-system-ffi";;
- Linux/ppc*) with_system_ffi="yes"; CONFIG_ARGS="$CONFIG_ARGS --with-system-ffi";;
- Linux/s390*) with_system_ffi="yes"; CONFIG_ARGS="$CONFIG_ARGS --with-system-ffi";;
- *) with_system_ffi="no"
- esac
-fi
AC_MSG_RESULT($with_system_ffi)
# Determine if signalmodule should be used.