summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlexandre Vassalotti <alexandre@peadrop.com>2009-07-17 06:33:51 (GMT)
committerAlexandre Vassalotti <alexandre@peadrop.com>2009-07-17 06:33:51 (GMT)
commite7cf1183fecbcaa97d99c80412111fb5cf7e5972 (patch)
tree3a7afa0407341c19f96285c98f6e095456e946cc /configure.in
parent1a3d085008afe2faed293be84587799938e902e1 (diff)
downloadcpython-e7cf1183fecbcaa97d99c80412111fb5cf7e5972.zip
cpython-e7cf1183fecbcaa97d99c80412111fb5cf7e5972.tar.gz
cpython-e7cf1183fecbcaa97d99c80412111fb5cf7e5972.tar.bz2
Double-quote the test case for %zd printf() format support to avoid
mangling the array declarations in it.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index a59c94b..2add992 100644
--- a/configure.in
+++ b/configure.in
@@ -3777,7 +3777,8 @@ fi
AC_MSG_CHECKING(for %zd printf() format support)
AC_CACHE_VAL(ac_cv_have_size_t_format,
-AC_TRY_RUN([#include <stdio.h>
+AC_TRY_RUN([[
+#include <stdio.h>
#include <stddef.h>
#include <string.h>
@@ -3811,9 +3812,9 @@ int main()
return 0;
}
-], ac_cv_have_size_t_format=yes,
- ac_cv_have_size_t_format=no,
- ac_cv_have_size_t_format=no)
+]], ac_cv_have_size_t_format=yes,
+ ac_cv_have_size_t_format=no,
+ ac_cv_have_size_t_format=no)
)
AC_MSG_RESULT($ac_cv_have_size_t_format)
if test $ac_cv_have_size_t_format = yes