summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMatthias Klose <doko@ubuntu.com>2007-10-24 20:00:44 (GMT)
committerMatthias Klose <doko@ubuntu.com>2007-10-24 20:00:44 (GMT)
commit9afb9850f28519879fdadaa9467a7bdb46b01417 (patch)
tree697e28173bdf2bb00d7446479a79e3548d0ac2e3 /configure.in
parente7becc5007b8600402697513bdc74579dbc630d2 (diff)
downloadcpython-9afb9850f28519879fdadaa9467a7bdb46b01417.zip
cpython-9afb9850f28519879fdadaa9467a7bdb46b01417.tar.gz
cpython-9afb9850f28519879fdadaa9467a7bdb46b01417.tar.bz2
- Build using system ffi library on arm*-linux*.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 7480ee6..2c5a85f 100644
--- a/configure.in
+++ b/configure.in
@@ -1748,12 +1748,16 @@ LIBS="$withval $LIBS"
[AC_MSG_RESULT(no)])
# Check for use of the system libffi library
+AC_CHECK_HEADER(ffi.h)
AC_MSG_CHECKING(for --with-system-ffi)
AC_ARG_WITH(system_ffi,
AC_HELP_STRING(--with-system-ffi, build _ctypes module using an installed ffi library))
-if test -z "$with_system_ffi"
-then with_system_ffi="no"
+if test -z "$with_system_ffi" && test "$ac_cv_header_ffi_h" = yes; then
+ case "$ac_sys_system/`uname -m`" in
+ Linux/arm*) with_system_ffi="yes";;
+ *) with_system_ffi="no"
+ esac
fi
AC_MSG_RESULT($with_system_ffi)