summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>2000-05-11 18:41:32 (GMT)
committerGuido van Rossum <guido@python.org>2000-05-11 18:41:32 (GMT)
commita28518a6a645710b5c8a78e3d98da4bac828d63e (patch)
treee73c3060dd7cda69f898c37fa83642ab27a12ba5 /configure.in
parent99f235d5e789deaaa68f3a9341f4cf896c914752 (diff)
downloadcpython-a28518a6a645710b5c8a78e3d98da4bac828d63e.zip
cpython-a28518a6a645710b5c8a78e3d98da4bac828d63e.tar.gz
cpython-a28518a6a645710b5c8a78e3d98da4bac828d63e.tar.bz2
Add check for rint() in math library.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 6a846a2..99d3eec 100644
--- a/configure.in
+++ b/configure.in
@@ -996,6 +996,12 @@ AC_CHECK_FUNCS(hypot)
AC_REPLACE_FUNCS(hypot)
LIBS=$LIBS_SAVE
+# check for rint() in math library
+LIBS_SAVE=$LIBS
+LIBS="$LIBS $LIBM"
+AC_CHECK_FUNCS(rint)
+LIBS=$LIBS_SAVE
+
# check for getopt
AC_MSG_CHECKING(for genuine getopt)
AC_CACHE_VAL(ac_cv_func_getopt,