summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>1999-11-16 15:57:37 (GMT)
committerGuido van Rossum <guido@python.org>1999-11-16 15:57:37 (GMT)
commit0eefa3fbbfa476334516dda1be398188f993c35d (patch)
treed695edee520f4ab010c08ff54a29fd61a0bf453b /configure.in
parent569ef619c70653a188f047d5fb7c06a898dff54b (diff)
downloadcpython-0eefa3fbbfa476334516dda1be398188f993c35d.zip
cpython-0eefa3fbbfa476334516dda1be398188f993c35d.tar.gz
cpython-0eefa3fbbfa476334516dda1be398188f993c35d.tar.bz2
Patch by Vladimir Marangozov, inspired by a bug report from Gary
Duzan, for AIX, to support C++ objects with static initializers, when using the genuine IBM C++ compiler (namely xlC/xlC_r). See accompanying patches to acconfig.h and importdl.c.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 2639635..3d3383c 100644
--- a/configure.in
+++ b/configure.in
@@ -543,6 +543,18 @@ AC_MSG_RESULT($LINKFORSHARED)
# checks for libraries
AC_CHECK_LIB(dl, dlopen) # Dynamic linking for SunOS/Solaris and SYSV
AC_CHECK_LIB(dld, shl_load) # Dynamic linking for HP-UX
+
+# checks for system dependent C++ extensions support
+case "$ac_sys_system" in
+ AIX*) AC_MSG_CHECKING(for genuine AIX C++ extensions support)
+ AC_TRY_LINK([#include "/usr/lpp/xlC/include/load.h"],
+ [loadAndInit("", 0, "")],
+ [AC_DEFINE(AIX_GENUINE_CPLUSPLUS)
+ AC_MSG_RESULT(yes)],
+ [AC_MSG_RESULT(no)]);;
+ *) ;;
+esac
+
# Most SVR4 platforms (e.g. Solaris) need -lsocket and -lnsl.
# However on SGI IRIX, these exist but are broken.
# BeOS' sockets are stashed in libnet.