summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGeorg Brandl <georg@python.org>2011-02-19 08:58:23 (GMT)
committerGeorg Brandl <georg@python.org>2011-02-19 08:58:23 (GMT)
commit216e404bca5485ca2bf837b9f351731c535702d8 (patch)
treec2b5e4fe9c9a589748415d876a5a022a0e2c6e93 /configure.in
parent6e8d17c06271d6841b6c8cc8f8cdf6ffd2ef6c70 (diff)
downloadcpython-216e404bca5485ca2bf837b9f351731c535702d8.zip
cpython-216e404bca5485ca2bf837b9f351731c535702d8.tar.gz
cpython-216e404bca5485ca2bf837b9f351731c535702d8.tar.bz2
#11184: Fix large file support on AIX.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 26d4f6c..6f4ffa5 100644
--- a/configure.in
+++ b/configure.in
@@ -1376,6 +1376,12 @@ fi
if test "$use_lfs" = "yes"; then
# Two defines needed to enable largefile support on various platforms
# These may affect some typedefs
+case $ac_sys_system/$ac_sys_release in
+AIX*)
+ AC_DEFINE(_LARGE_FILES, 1,
+ [This must be defined on AIX systems to enable large file support.])
+ ;;
+esac
AC_DEFINE(_LARGEFILE_SOURCE, 1,
[This must be defined on some systems to enable large file support.])
AC_DEFINE(_FILE_OFFSET_BITS, 64,