summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMark Dickinson <dickinsm@gmail.com>2008-04-22 00:54:27 (GMT)
committerMark Dickinson <dickinsm@gmail.com>2008-04-22 00:54:27 (GMT)
commit7a3d8641a97fb852198c445ff18b6ee29fd01a51 (patch)
tree4935f9e1912499887902dd86838b6aa7959b65ac /configure.in
parent60ffcbe88bf7552667a6f8693f4bc3e38ed625f8 (diff)
downloadcpython-7a3d8641a97fb852198c445ff18b6ee29fd01a51.zip
cpython-7a3d8641a97fb852198c445ff18b6ee29fd01a51.tar.gz
cpython-7a3d8641a97fb852198c445ff18b6ee29fd01a51.tar.bz2
Make configure test for tanh(-0.) == -0. committed in r62447 actually
work. (The test wasn't properly linked with libm. Sigh.)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 4d72321..a246b2d 100644
--- a/configure.in
+++ b/configure.in
@@ -2995,12 +2995,16 @@ fi],
# * Check for mathematical functions *
# ************************************
+LIBS_SAVE=$LIBS
+LIBS="$LIBS $LIBM"
+
# On FreeBSD 6.2, it appears that tanh(-0.) returns 0. instead of
# -0. on some architectures.
AC_MSG_CHECKING(whether tanh preserves the sign of zero)
AC_CACHE_VAL(ac_cv_tanh_preserves_zero_sign, [
AC_TRY_RUN([
#include <math.h>
+#include <stdlib.h>
int main() {
/* return 0 if either negative zeros don't exist
on this platform or if negative zeros exist
@@ -3020,8 +3024,6 @@ then
[Define if tanh(-0.) is -0., or if platform doesn't have signed zeros])
fi
-LIBS_SAVE=$LIBS
-LIBS="$LIBS $LIBM"
AC_REPLACE_FUNCS(hypot)
AC_CHECK_FUNCS(acosh asinh atanh copysign expm1 finite isinf isnan log1p)