summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorCharles-François Natali <neologix@free.fr>2011-05-29 18:07:40 (GMT)
committerCharles-François Natali <neologix@free.fr>2011-05-29 18:07:40 (GMT)
commitdaafdd5bea1edb0fa980727cf8c52bfe7928d6b8 (patch)
tree9a508518d3a596ce11436bff47ada935011c177b /configure.in
parent04a90b4611d3a20ac593860d7f4156a14723e84a (diff)
downloadcpython-daafdd5bea1edb0fa980727cf8c52bfe7928d6b8.zip
cpython-daafdd5bea1edb0fa980727cf8c52bfe7928d6b8.tar.gz
cpython-daafdd5bea1edb0fa980727cf8c52bfe7928d6b8.tar.bz2
Issue #12196: Add pipe2() to the os module.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 1 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 3bf46b0..b5f155d 100644
--- a/configure.in
+++ b/configure.in
@@ -2531,7 +2531,7 @@ AC_CHECK_FUNCS(alarm accept4 setitimer getitimer bind_textdomain_codeset chown \
getpriority getresuid getresgid getpwent getspnam getspent getsid getwd \
if_nameindex \
initgroups kill killpg lchmod lchown lockf linkat lstat lutimes mbrtowc mkdirat mkfifo \
- mkfifoat mknod mknodat mktime mremap nice openat pathconf pause plock poll \
+ mkfifoat mknod mknodat mktime mremap nice openat pathconf pause pipe2 plock poll \
posix_fallocate posix_fadvise pread \
pthread_init pthread_kill putenv pwrite readlink readlinkat readv realpath renameat \
select sem_open sem_timedwait sem_getvalue sem_unlink sendfile setegid seteuid \
@@ -4244,8 +4244,6 @@ AIX*)
esac
-AC_CHECK_FUNC(pipe2, AC_DEFINE(HAVE_PIPE2, 1, [Define if the OS supports pipe2()]), )
-
AC_SUBST(THREADHEADERS)
for h in `(cd $srcdir;echo Python/thread_*.h)`