summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRonald Oussoren <ronaldoussoren@mac.com>2009-09-06 11:01:15 (GMT)
committerRonald Oussoren <ronaldoussoren@mac.com>2009-09-06 11:01:15 (GMT)
commit5bbab3e64fcff14f9e21b3bc07096f443a37aa38 (patch)
treebd08c0be499ca1170680a3d87c42e9a29f565ddd /configure.in
parent2b6705fb1c8aa6d7a50647cd9007bd8e6b33af07 (diff)
downloadcpython-5bbab3e64fcff14f9e21b3bc07096f443a37aa38.zip
cpython-5bbab3e64fcff14f9e21b3bc07096f443a37aa38.tar.gz
cpython-5bbab3e64fcff14f9e21b3bc07096f443a37aa38.tar.bz2
Merged revisions 74672 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk ........ r74672 | ronald.oussoren | 2009-09-06 12:00:26 +0200 (Sun, 06 Sep 2009) | 1 line Fix build issues on OSX 10.6 (issue 6802) ........
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in71
1 files changed, 62 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 2c5fa69..01d7585 100644
--- a/configure.in
+++ b/configure.in
@@ -109,7 +109,6 @@ AC_ARG_ENABLE(universalsdk,
])
AC_SUBST(UNIVERSALSDK)
-ARCH_RUN_32BIT=
AC_SUBST(ARCH_RUN_32BIT)
UNIVERSAL_ARCHS="32-bit"
@@ -920,6 +919,7 @@ yes)
elif test "$UNIVERSAL_ARCHS" = "64-bit" ; then
UNIVERSAL_ARCH_FLAGS="-arch ppc64 -arch x86_64"
+ ARCH_RUN_32BIT="true"
elif test "$UNIVERSAL_ARCHS" = "all" ; then
UNIVERSAL_ARCH_FLAGS="-arch i386 -arch ppc -arch ppc64 -arch x86_64"
@@ -943,12 +943,22 @@ yes)
cur_target=`sw_vers -productVersion | sed 's/\(10\.[[0-9]]*\).*/\1/'`
if test ${cur_target} '>' 10.2; then
cur_target=10.3
- fi
- if test "${UNIVERSAL_ARCHS}" = "all"; then
- # Ensure that the default platform for a 4-way
- # universal build is OSX 10.5, that's the first
- # OS release where 4-way builds make sense.
- cur_target='10.5'
+ if test ${enable_universalsdk}; then
+ if test "${UNIVERSAL_ARCHS}" = "all"; then
+ # Ensure that the default platform for a
+ # 4-way universal build is OSX 10.5,
+ # that's the first OS release where
+ # 4-way builds make sense.
+ cur_target='10.5'
+ fi
+ else
+ if test `arch` = "i386"; then
+ # On Intel macs default to a deployment
+ # target of 10.4, that's the first OSX
+ # release with Intel support.
+ cur_target="10.4"
+ fi
+ fi
fi
CONFIGURE_MACOSX_DEPLOYMENT_TARGET=${MACOSX_DEPLOYMENT_TARGET-${cur_target}}
@@ -1455,6 +1465,8 @@ case $ac_sys_system/$ac_sys_release in
;;
esac
+
+ARCH_RUN_32BIT=""
AC_SUBST(LIBTOOL_CRUFT)
case $ac_sys_system/$ac_sys_release in
Darwin/@<:@01567@:>@\..*)
@@ -1462,7 +1474,7 @@ case $ac_sys_system/$ac_sys_release in
if test "${enable_universalsdk}"; then
:
else
- LIBTOOL_CRUFT="${LIBTOOL_CRUFT} -arch_only `arch`"
+ LIBTOOL_CRUFT="${LIBTOOL_CRUFT} -arch_only `arch`"
fi
LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -install_name $(PYTHONFRAMEWORKINSTALLDIR)/Versions/$(VERSION)/$(PYTHONFRAMEWORK)'
LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -compatibility_version $(VERSION) -current_version $(VERSION)';;
@@ -1474,7 +1486,48 @@ case $ac_sys_system/$ac_sys_release in
else
LIBTOOL_CRUFT=""
fi
- LIBTOOL_CRUFT=$LIBTOOL_CRUFT" -lSystem -lSystemStubs -arch_only `arch`"
+ AC_TRY_RUN([[
+ #include <unistd.h>
+ int main(int argc, char*argv[])
+ {
+ if (sizeof(long) == 4) {
+ return 0;
+ } else {
+ return 1;
+ }
+ ]], ac_osx_32bit=yes,
+ ac_osx_32bit=no,
+ ac_osx_32bit=no)
+
+ if test "${ac_osx_32bit}" = "yes"; then
+ case `arch` in
+ i386)
+ MACOSX_DEFAULT_ARCH="i386"
+ ;;
+ ppc)
+ MACOSX_DEFAULT_ARCH="ppc"
+ ;;
+ *)
+ AC_MSG_ERROR([Unexpected output of 'arch' on OSX])
+ ;;
+ esac
+ else
+ case `arch` in
+ i386)
+ MACOSX_DEFAULT_ARCH="x86_64"
+ ;;
+ ppc)
+ MACOSX_DEFAULT_ARCH="ppc64"
+ ;;
+ *)
+ AC_MSG_ERROR([Unexpected output of 'arch' on OSX])
+ ;;
+ esac
+
+ #ARCH_RUN_32BIT="true"
+ fi
+
+ LIBTOOL_CRUFT=$LIBTOOL_CRUFT" -lSystem -lSystemStubs -arch_only ${MACOSX_DEFAULT_ARCH}"
LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -install_name $(PYTHONFRAMEWORKINSTALLDIR)/Versions/$(VERSION)/$(PYTHONFRAMEWORK)'
LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -compatibility_version $(VERSION) -current_version $(VERSION)';;
esac