summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>2000-05-18 20:53:31 (GMT)
committerGuido van Rossum <guido@python.org>2000-05-18 20:53:31 (GMT)
commit95713eb9d6e410f9fe4b671f5d9120ea03f19636 (patch)
tree28677ea8924e34f02e1db48e9c680360bea81f83 /configure.in
parent8c5cedee697d9dc6985cc6b2be7524dd5fcc0b62 (diff)
downloadcpython-95713eb9d6e410f9fe4b671f5d9120ea03f19636.zip
cpython-95713eb9d6e410f9fe4b671f5d9120ea03f19636.tar.gz
cpython-95713eb9d6e410f9fe4b671f5d9120ea03f19636.tar.bz2
Fix the test for socklen_t so that it searches through sys/socket.h.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 99d3eec..3e4fb37 100644
--- a/configure.in
+++ b/configure.in
@@ -356,7 +356,7 @@ AC_HEADER_STDC
AC_CHECK_HEADERS(dlfcn.h fcntl.h limits.h locale.h ncurses.h pthread.h \
signal.h stdarg.h stddef.h stdlib.h thread.h unistd.h utime.h \
sys/audioio.h sys/file.h sys/lock.h \
-sys/param.h sys/select.h sys/time.h sys/times.h \
+sys/param.h sys/select.h sys/socket.h sys/time.h sys/times.h \
sys/un.h sys/utsname.h sys/wait.h)
AC_HEADER_DIRENT
@@ -380,7 +380,6 @@ AC_TYPE_PID_T
AC_TYPE_SIGNAL
AC_TYPE_SIZE_T
AC_TYPE_UID_T
-AC_CHECK_TYPE(socklen_t, int)
# Sizes of various common basic types
AC_CHECK_SIZEOF(int)
@@ -1080,6 +1079,15 @@ else AC_MSG_RESULT(no)
fi],
[AC_MSG_RESULT(no)])
+# THIS MUST BE LAST, IT CAN BREAK OTHER TESTS!
+# Add sys/socket.h to confdefs.h
+cat >> confdefs.h <<\EOF
+#ifdef HAVE_SYS_SOCKET_H
+#include <sys/socket.h>
+#endif
+EOF
+AC_CHECK_TYPE(socklen_t, int)
+
# generate output files
AC_OUTPUT(Makefile \
Objects/Makefile \