summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorNeal Norwitz <nnorwitz@gmail.com>2006-03-31 06:54:45 (GMT)
committerNeal Norwitz <nnorwitz@gmail.com>2006-03-31 06:54:45 (GMT)
commitdedeeaad040cdcb3c72b6f89cd33cc0264ea908d (patch)
tree6a2194c31ece73a3d70d644f0c86fff20bb8faa8 /configure.in
parent7b8cf389274c33a94879deed3141a3a7c627a946 (diff)
downloadcpython-dedeeaad040cdcb3c72b6f89cd33cc0264ea908d.zip
cpython-dedeeaad040cdcb3c72b6f89cd33cc0264ea908d.tar.gz
cpython-dedeeaad040cdcb3c72b6f89cd33cc0264ea908d.tar.bz2
Get gcc to do strict IEEE math. This flag was already used for cc, just not
gcc. Without this flag, doing pretty much anything with NaNs causes a Floating Point Exception signal. This causes the interpreter to quit. The failing tests this fixes are: test_float, test_long, and test_struct. This is somewhat equivalent to doing signal(SIGFPE, SIG_IGN). Will verify if this is a problem in 2.4 and backport if necessary (probably).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 5d9ec56..8a73c4f 100644
--- a/configure.in
+++ b/configure.in
@@ -746,6 +746,9 @@ yes)
Darwin*)
BASECFLAGS="$BASECFLAGS -Wno-long-double -no-cpp-precomp -mno-fused-madd"
;;
+ OSF*)
+ BASECFLAGS="$BASECFLAGS -mieee"
+ ;;
esac
;;