summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJeffrey Yasskin <jyasskin@gmail.com>2008-03-17 14:40:53 (GMT)
committerJeffrey Yasskin <jyasskin@gmail.com>2008-03-17 14:40:53 (GMT)
commit1b4e45bab940d385386e9442de5f5fbc7983dd50 (patch)
tree327770749098ca8755bd420adbf3437f64aff6a9 /configure.in
parent5c35a9da65766da56d5f89882ecf43028fbf7322 (diff)
downloadcpython-1b4e45bab940d385386e9442de5f5fbc7983dd50.zip
cpython-1b4e45bab940d385386e9442de5f5fbc7983dd50.tar.gz
cpython-1b4e45bab940d385386e9442de5f5fbc7983dd50.tar.bz2
Allow Gnu gcc's to build python on OSX by removing -Wno-long-double,
-no-cpp-precomp, and -mno-fused-madd from configure. * r22183 added -no-cpp-precomp, which http://gcc.gnu.org/ml/gcc/2005-12/msg00368.html claims hasn't been needed since gcc-3.1. * r25607 added -Wno-long-double to avoid a warning in Include/objimpl.h (issue 525481). The long double is still there, but OSX 10.4's gcc no longer warns about it. * r33666 fixed issue 775892 on OSX 10.3 by adding -mno-fused-madd, which changed the sign of some float 0s. Tim Peters said it wasn't a real issue anyway, and it no longer causes test failures. Fixes issue #1779871.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index e731825..767766c 100644
--- a/configure.in
+++ b/configure.in
@@ -823,7 +823,8 @@ yes)
;;
# is there any other compiler on Darwin besides gcc?
Darwin*)
- BASECFLAGS="$BASECFLAGS -Wno-long-double -no-cpp-precomp -mno-fused-madd"
+ # -Wno-long-double, -no-cpp-precomp, and -mno-fused-madd
+ # used to be here, but non-Apple gcc doesn't accept them.
if test "${enable_universalsdk}"; then
BASECFLAGS="-arch ppc -arch i386 -isysroot ${UNIVERSALSDK} ${BASECFLAGS}"
fi