summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>1997-05-14 21:14:44 (GMT)
committerGuido van Rossum <guido@python.org>1997-05-14 21:14:44 (GMT)
commit201afe56d3ccd70e1beb354e168d3ff93ad36a25 (patch)
tree1c8ab9010f1d0fc0a817f4504c9671d8959521aa /configure.in
parent2b4d2800af0e9251515b7aab114ae6307dd4d475 (diff)
downloadcpython-201afe56d3ccd70e1beb354e168d3ff93ad36a25.zip
cpython-201afe56d3ccd70e1beb354e168d3ff93ad36a25.tar.gz
cpython-201afe56d3ccd70e1beb354e168d3ff93ad36a25.tar.bz2
Add -Olimit 1500 to OPT if CC supports it.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 616851a..16c0cf2 100644
--- a/configure.in
+++ b/configure.in
@@ -111,6 +111,19 @@ fi
AC_AIX
AC_MINIX
+AC_MSG_CHECKING(whether $CC accepts -Olimit 1500)
+AC_CACHE_VAL(ac_cv_olimit_ok,
+[ac_save_cc="$CC"
+CC="$CC -Olimit 1500"
+AC_TRY_COMPILE([], [;],
+ ac_cv_olimit_ok=yes,
+ ac_cv_olimit_ok=no)
+CC="$ac_save_cc"])
+AC_MSG_RESULT($ac_cv_olimit_ok)
+if test $ac_cv_olimit_ok = yes; then
+ OPT="$OPT -Olimit 1500"
+fi
+
# check for ANSI or K&R ("traditional") preprocessor
AC_MSG_CHECKING(for C preprocessor type)
AC_TRY_COMPILE([