summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorVictor Stinner <victor.stinner@haypocalc.com>2011-11-24 12:53:38 (GMT)
committerVictor Stinner <victor.stinner@haypocalc.com>2011-11-24 12:53:38 (GMT)
commit984890fcbbb2bb9d7168fd78a1383804593c3fd3 (patch)
tree6bfdaf51f6d170bca2fad95b42b2d1aabb0dfe25 /configure.in
parent1518e8713d1e372284c653f254fb29cecc66d764 (diff)
downloadcpython-984890fcbbb2bb9d7168fd78a1383804593c3fd3.zip
cpython-984890fcbbb2bb9d7168fd78a1383804593c3fd3.tar.gz
cpython-984890fcbbb2bb9d7168fd78a1383804593c3fd3.tar.bz2
Close #13415: Test in configure if unsetenv() has a return value or not.
Patch written by Charles-François Natali.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 532ec92..b41e750 100644
--- a/configure.in
+++ b/configure.in
@@ -2688,6 +2688,15 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
[AC_MSG_RESULT(no)
])
+AC_MSG_CHECKING(for broken unsetenv)
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+#include <stdlib.h>
+]], [[int res = unsetenv("DUMMY")]])],
+ [AC_MSG_RESULT(no)],
+ [AC_DEFINE(HAVE_BROKEN_UNSETENV, 1, Define if `unsetenv` does not return an int.)
+ AC_MSG_RESULT(yes)
+])
+
dnl check for true
AC_CHECK_PROGS(TRUE, true, /bin/true)