summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGreg Ward <gward@python.net>2000-11-07 15:44:21 (GMT)
committerGreg Ward <gward@python.net>2000-11-07 15:44:21 (GMT)
commita1c4da2481c428b06f144b625d52df52106a5ff6 (patch)
tree92098d11a7f6e52f1adad030d05135c42838c343 /configure.in
parentf16e0ed76c312ecddac1a90a713a865cc4b20b05 (diff)
downloadcpython-a1c4da2481c428b06f144b625d52df52106a5ff6.zip
cpython-a1c4da2481c428b06f144b625d52df52106a5ff6.tar.gz
cpython-a1c4da2481c428b06f144b625d52df52106a5ff6.tar.bz2
Fix for SF bug #117606:
- when compiling with GCC on Solaris, use "$(CC) -shared" instead of "$(CC) -G" to generate .so files - when compiling with GCC on any platform, add "-fPIC" to OPT (without this, "$(CC) -shared" dies horribly)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index f201748..8bfb147 100644
--- a/configure.in
+++ b/configure.in
@@ -308,8 +308,8 @@ then
case $GCC in
yes)
case $ac_cv_prog_cc_g in
- yes) OPT="-g -O2 -Wall -Wstrict-prototypes";;
- *) OPT="-O2 -Wall -Wstrict-prototypes";;
+ yes) OPT="-g -O2 -Wall -Wstrict-prototypes -fPIC";;
+ *) OPT="-O2 -Wall -Wstrict-prototypes -fPIC";;
esac
;;
*) OPT="-O";;
@@ -564,7 +564,7 @@ then
SunOS/4*) LDSHARED="ld";;
SunOS/5*)
if test "$GCC" = "yes"
- then LDSHARED='$(CC) -G'
+ then LDSHARED='$(CC) -shared'
else LDSHARED="ld -G";
fi ;;
hp*|HP*) LDSHARED="ld -b";;