summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMatthias Klose <doko@ubuntu.com>2004-08-16 11:35:51 (GMT)
committerMatthias Klose <doko@ubuntu.com>2004-08-16 11:35:51 (GMT)
commita2542bee597cbbc382d17ad6bd7ad4fce09d71b8 (patch)
treee90e031dda0c1fdad7f8d09117803bdf7e4840bd /configure.in
parentd3fe2395b4f85f307d437f5b5b1f69e297d1fe11 (diff)
downloadcpython-a2542bee597cbbc382d17ad6bd7ad4fce09d71b8.zip
cpython-a2542bee597cbbc382d17ad6bd7ad4fce09d71b8.tar.gz
cpython-a2542bee597cbbc382d17ad6bd7ad4fce09d71b8.tar.bz2
The attached patch fixes FTBFS on GNU/k*BSD. The problem happens on GNU/k*BSD
because GNU/k*BSD uses gnu pth to provide pthreads, but will also happen on any system that does the same. python fails to build because it doesn't detect gnu pth in pthread emulation. See C comments in patch for details. patch taken from http://bugs.debian.org/264315
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index f0a1bda..60ad582 100644
--- a/configure.in
+++ b/configure.in
@@ -1628,7 +1628,8 @@ else
fi
# According to the POSIX spec, a pthreads implementation must
- # define _POSIX_THREADS in unistd.h. Some apparently don't (which ones?)
+ # define _POSIX_THREADS in unistd.h. Some apparently don't
+ # (e.g. gnu pth with pthread emulation)
AC_MSG_CHECKING(for _POSIX_THREADS in unistd.h)
AC_EGREP_CPP(yes,
[