summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorTrent Mick <trentm@activestate.com>2004-08-25 23:55:59 (GMT)
committerTrent Mick <trentm@activestate.com>2004-08-25 23:55:59 (GMT)
commitaf16e8c390a49eefd7ce33349769141b54e1cc9b (patch)
treea8a62b9970959d4df778ab3e1ad81a77e4705159 /configure.in
parent19b1958730f290ad6bf309653d76f222906f0c41 (diff)
downloadcpython-af16e8c390a49eefd7ce33349769141b54e1cc9b.zip
cpython-af16e8c390a49eefd7ce33349769141b54e1cc9b.tar.gz
cpython-af16e8c390a49eefd7ce33349769141b54e1cc9b.tar.bz2
Apply patch #1016224: configure.in change to allow build of _bsddb module on
AIX 5.1.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 60ad582..1e02983 100644
--- a/configure.in
+++ b/configure.in
@@ -161,11 +161,16 @@ case $ac_sys_system/$ac_sys_release in
# This should hopefully be fixed in FreeBSD 4.9
FreeBSD/4.8* | Darwin/6* )
define_xopen_source=no;;
- # On AIX 4, mbstate_t is defined only when _XOPEN_SOURCE == 500 but used in
- # wcsnrtombs() and mbsnrtowcs() even if _XOPEN_SOURCE is not defined or
- # has another value. By not (re)defining it, the defaults come in place.
+ # On AIX 4 and 5.1, mbstate_t is defined only when _XOPEN_SOURCE == 500 but
+ # used in wcsnrtombs() and mbsnrtowcs() even if _XOPEN_SOURCE is not defined
+ # or has another value. By not (re)defining it, the defaults come in place.
AIX/4)
define_xopen_source=no;;
+ AIX/5)
+ if test `uname -r` -eq 1; then
+ define_xopen_source=no
+ fi
+ ;;
esac
if test $define_xopen_source = yes