summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMark Dickinson <dickinsm@gmail.com>2010-05-05 22:31:36 (GMT)
committerMark Dickinson <dickinsm@gmail.com>2010-05-05 22:31:36 (GMT)
commitb2153e9d08b95c12c82b3d75cfaba837734c561b (patch)
tree259fb82df1d0dea5ad0bdd7360a4ac64cab1d9fc /configure.in
parentae4d5c6b643c3efeb5f7b43ca9108978b388ab34 (diff)
downloadcpython-b2153e9d08b95c12c82b3d75cfaba837734c561b.zip
cpython-b2153e9d08b95c12c82b3d75cfaba837734c561b.tar.gz
cpython-b2153e9d08b95c12c82b3d75cfaba837734c561b.tar.bz2
Merged revisions 80832 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk ........ r80832 | mark.dickinson | 2010-05-05 23:23:58 +0100 (Wed, 05 May 2010) | 2 lines Issue #8625: Turn off gcc optimization in debug builds. ........
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 7aa86d4..5993e05 100644
--- a/configure.in
+++ b/configure.in
@@ -875,7 +875,7 @@ then
if test "$Py_DEBUG" = 'true' ; then
# Optimization messes up debuggers, so turn it off for
# debug builds.
- OPT="-g -Wall $STRICT_PROTO"
+ OPT="-g -O0 -Wall $STRICT_PROTO"
else
OPT="-g $WRAP -O3 -Wall $STRICT_PROTO"
fi