summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorTarek Ziadé <ziade.tarek@gmail.com>2009-05-09 11:55:12 (GMT)
committerTarek Ziadé <ziade.tarek@gmail.com>2009-05-09 11:55:12 (GMT)
commitbe720e0369b6b8a97ceab4a4f8f8930911bd1b75 (patch)
tree6aaa74a6fd2431eeabfadf5e1efe27d5d2ca0017 /configure.in
parentbe5b1b99737271a1f7d9748203b7ee116dd0ce61 (diff)
downloadcpython-be720e0369b6b8a97ceab4a4f8f8930911bd1b75.zip
cpython-be720e0369b6b8a97ceab4a4f8f8930911bd1b75.tar.gz
cpython-be720e0369b6b8a97ceab4a4f8f8930911bd1b75.tar.bz2
Merged revisions 72497 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk ........ r72497 | tarek.ziade | 2009-05-09 10:28:53 +0200 (Sat, 09 May 2009) | 1 line Fixed Issue 5900: distutils.command.build_ext - Ensure RUNPATH is added to extension modules with RPATH if GNU ld is used ........
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 2591d8d..176e5cd 100644
--- a/configure.in
+++ b/configure.in
@@ -606,6 +606,25 @@ then
fi
AC_MSG_RESULT($LINKCC)
+# GNULD is set to "yes" if the GNU linker is used. If this goes wrong
+# make sure we default having it set to "no": this is used by
+# distutils.unixccompiler to know if it should add --enable-new-dtags
+# to linker command lines, and failing to detect GNU ld simply results
+# in the same bahaviour as before.
+AC_SUBST(GNULD)
+AC_MSG_CHECKING(for GNU ld)
+ac_prog=ld
+if test "$GCC" = yes; then
+ ac_prog=`$CC -print-prog-name=ld`
+fi
+case `"$ac_prog" -V 2>&1 < /dev/null` in
+ *GNU*)
+ GNULD=yes;;
+ *)
+ GNULD=no;;
+esac
+AC_MSG_RESULT($GNULD)
+
AC_MSG_CHECKING(for --enable-shared)
AC_ARG_ENABLE(shared,
AC_HELP_STRING(--enable-shared, disable/enable building shared python library))