summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRonald Oussoren <ronaldoussoren@mac.com>2009-11-19 17:30:05 (GMT)
committerRonald Oussoren <ronaldoussoren@mac.com>2009-11-19 17:30:05 (GMT)
commit1b2cad00c7fa2280917cb62ecccb3e129d9299c9 (patch)
tree7da6bf94476d0819561bd445a82bad0ba2a723a7 /configure.in
parentfd9ac226aa040b2cc790e7818d4e973ddf65b025 (diff)
downloadcpython-1b2cad00c7fa2280917cb62ecccb3e129d9299c9.zip
cpython-1b2cad00c7fa2280917cb62ecccb3e129d9299c9.tar.gz
cpython-1b2cad00c7fa2280917cb62ecccb3e129d9299c9.tar.bz2
Merged revisions 76405 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/branches/py3k ................ r76405 | ronald.oussoren | 2009-11-19 18:15:31 +0100 (Thu, 19 Nov 2009) | 21 lines Merged revisions 76403 via svnmerge from svn+ssh://pythondev@svn.python.org/python/trunk ........ r76403 | ronald.oussoren | 2009-11-19 17:25:21 +0100 (Thu, 19 Nov 2009) | 14 lines Fix for issue #7085 On MacOSX 10.6 the CoreFoundation framework must be initialized on the main thread, the constructor function in that framework will cause an SIGABRT when it is called on any other thread. Because a number of extension link (indirectly) to CoreFoundation and the Python core itself didn't the interpreter crashed when importing some extensions, such as _locale, on a secondary thread. This fix ensures that Python is linked to CoreFoundation on OSX, which results in the CoreFoundation constructor being called when Python is loaded. This does not require code changes. ........ ................
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 5651993..1d024cd 100644
--- a/configure.in
+++ b/configure.in
@@ -3939,6 +3939,12 @@ else AC_MSG_RESULT(no)
fi],
[AC_MSG_RESULT(no)])
+if test $ac_sys_system = Darwin
+then
+ LIBS="$LIBS -framework CoreFoundation"
+fi
+
+
AC_SUBST(THREADHEADERS)