summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGeorg Brandl <georg@python.org>2011-03-05 19:51:24 (GMT)
committerGeorg Brandl <georg@python.org>2011-03-05 19:51:24 (GMT)
commit1ca2e7965c52525684bb517401c513158a8af989 (patch)
treebb4d18504b81ba63fc7b46ebf05d839b51338dd7 /configure.in
parent7b50c2c6aed2754f205835420d7450f2e401ebfd (diff)
downloadcpython-1ca2e7965c52525684bb517401c513158a8af989.zip
cpython-1ca2e7965c52525684bb517401c513158a8af989.tar.gz
cpython-1ca2e7965c52525684bb517401c513158a8af989.tar.bz2
Commit the hg build identification patch from the pymigr repo.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d1833be..3c6bd6f 100644
--- a/configure.in
+++ b/configure.in
@@ -785,6 +785,21 @@ else
SVNVERSION="echo Unversioned directory"
fi
+AC_SUBST(HGVERSION)
+AC_SUBST(HGTAG)
+AC_SUBST(HGBRANCH)
+AC_CHECK_PROG(HAS_HG, hg, found, not-found)
+if test $HAS_HG = found
+then
+ HGVERSION="hg id -i \$(srcdir)"
+ HGTAG="hg id -t \$(srcdir)"
+ HGBRANCH="hg id -b \$(srcdir)"
+else
+ HGVERSION=""
+ HGTAG=""
+ HGBRANCH=""
+fi
+
case $MACHDEP in
bsdos*|hp*|HP*)
# install -d does not work on BSDI or HP-UX