summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>1994-10-20 22:06:56 (GMT)
committerGuido van Rossum <guido@python.org>1994-10-20 22:06:56 (GMT)
commit2bcafeb6453c1b54e55bc4a85951298d4b594bda (patch)
tree694e7ed3f1aa6e74182d1cf79f52ff46ba7d330a /configure.in
parent904127924e0034d96a303da7646613436c37ba8d (diff)
downloadcpython-2bcafeb6453c1b54e55bc4a85951298d4b594bda.zip
cpython-2bcafeb6453c1b54e55bc4a85951298d4b594bda.tar.gz
cpython-2bcafeb6453c1b54e55bc4a85951298d4b594bda.tar.bz2
test for presence of stddef.h
separate arg requirements for getpgrp() and setpgrp()
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 6ca1f5a..2d2adb3 100644
--- a/configure.in
+++ b/configure.in
@@ -46,7 +46,7 @@ main() { exit(0); }
# checks for header files
AC_STDC_HEADERS
-AC_HAVE_HEADERS(dlfcn.h fcntl.h limits.h signal.h stdarg.h stdlib.h thread.h unistd.h utime.h sys/audioio.h sys/param.h sys/select.h sys/time.h sys/times.h sys/un.h sys/utsname.h)
+AC_HAVE_HEADERS(dlfcn.h fcntl.h limits.h signal.h stdarg.h stddef.h stdlib.h thread.h unistd.h utime.h sys/audioio.h sys/param.h sys/select.h sys/time.h sys/times.h sys/un.h sys/utsname.h)
AC_DIR_HEADER
# checks for typedefs
@@ -196,6 +196,7 @@ LIBS="$LIBS -ldl -ldld"])
AC_HAVE_FUNCS(chown clock dlopen ftime gettimeofday getpeername getpgrp getpid getwd link lstat nice readlink select setgid setuid setsid setpgid setpgrp setvbuf siginterrupt symlink tcgetpgrp tcsetpgrp times uname waitpid)
AC_REPLACE_FUNCS(dup2 getcwd strerror memmove)
AC_FUNC_CHECK(getpgrp, AC_COMPILE_CHECK([argument to getpgrp], [#include <unistd.h>], [getpgrp(0);], AC_DEFINE(GETPGRP_HAVE_ARG)))
++ AC_FUNC_CHECK(setpgrp, AC_COMPILE_CHECK([arguments to setpgrp], [#include <unistd.h>], [setpgrp(0,0);], AC_DEFINE(SETPGRP_HAVE_ARG)))
# checks for structures
AC_TIME_WITH_SYS_TIME