summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDave Cole <djc@object-craft.com.au>2004-08-09 04:51:41 (GMT)
committerDave Cole <djc@object-craft.com.au>2004-08-09 04:51:41 (GMT)
commit331708b226db74e745ef9972f9d4177348e4399d (patch)
treed0fece579509cedd357e981e2213cebf1e241967 /configure.in
parent80e53141b9227c39b7edb4677b8b1c14551866ec (diff)
downloadcpython-331708b226db74e745ef9972f9d4177348e4399d.zip
cpython-331708b226db74e745ef9972f9d4177348e4399d.tar.gz
cpython-331708b226db74e745ef9972f9d4177348e4399d.tar.bz2
Patch #1003700: Add socketpair function to socket module.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index f73d1ce..fbd436b 100644
--- a/configure.in
+++ b/configure.in
@@ -2468,6 +2468,17 @@ int foo(int x, ...) {
])
AC_MSG_RESULT($works)
+# check for socketpair
+AC_MSG_CHECKING(for socketpair)
+AC_TRY_COMPILE([
+#include <sys/types.h>
+#include <sys/socket.h>
+], void *x=socketpair,
+ AC_DEFINE(HAVE_SOCKETPAIR, 1, Define if you have the 'socketpair' function.)
+ AC_MSG_RESULT(yes),
+ AC_MSG_RESULT(no)
+)
+
# check if sockaddr has sa_len member
AC_MSG_CHECKING(if sockaddr has sa_len member)
AC_TRY_COMPILE([#include <sys/types.h>