summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJeffrey Yasskin <jyasskin@gmail.com>2010-05-03 19:29:34 (GMT)
committerJeffrey Yasskin <jyasskin@gmail.com>2010-05-03 19:29:34 (GMT)
commit39370830a96068ecbad006fe38fdb13107d8cd6b (patch)
tree80469ca84c0bf45573c3a83bfd8b7adca6cb97b0 /configure.in
parent6be8876623ffab3f2d1e4af46e7ce169d84b35a6 (diff)
downloadcpython-39370830a96068ecbad006fe38fdb13107d8cd6b.zip
cpython-39370830a96068ecbad006fe38fdb13107d8cd6b.tar.gz
cpython-39370830a96068ecbad006fe38fdb13107d8cd6b.tar.bz2
Make (most of) Python's tests pass under Thread Sanitizer.
http://code.google.com/p/data-race-test/wiki/ThreadSanitizer is a dynamic data race detector that runs on top of valgrind. With this patch, the binaries at http://code.google.com/p/data-race-test/wiki/ThreadSanitizer#Binaries pass many but not all of the Python tests. All of regrtest still passes outside of tsan. I've implemented part of the C1x atomic types so that we can explicitly mark variables that are used across threads, and get defined behavior as compilers advance. I've added tsan's client header and implementation to the codebase in dynamic_annotations.{h,c} (docs at http://code.google.com/p/data-race-test/wiki/DynamicAnnotations). Unfortunately, I haven't been able to get helgrind and drd to give sensible error messages, even when I use their client annotations, so I'm not supporting them.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 0cd867c..f991823 100644
--- a/configure.in
+++ b/configure.in
@@ -2515,6 +2515,7 @@ if test "$with_valgrind" != no; then
[AC_DEFINE([WITH_VALGRIND], 1, [Define if you want pymalloc to be disabled when running under valgrind])],
[AC_MSG_ERROR([Valgrind support requested but headers not available])]
)
+ OPT="-DDYNAMIC_ANNOTATIONS_ENABLED=1 $OPT"
fi
# Check for --with-wctype-functions