summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorNicholas Bastin <nick.bastin@gmail.com>2004-06-22 03:51:38 (GMT)
committerNicholas Bastin <nick.bastin@gmail.com>2004-06-22 03:51:38 (GMT)
commit4c70b69fb19ce5d730a70ab5d67272bb7202bd6c (patch)
tree16693f8610a4e259acaa4604c8cc40f04081f683 /configure.in
parent9c18e81fb23d60ea77bdf4f3c2649296f26e4a95 (diff)
downloadcpython-4c70b69fb19ce5d730a70ab5d67272bb7202bd6c.zip
cpython-4c70b69fb19ce5d730a70ab5d67272bb7202bd6c.tar.gz
cpython-4c70b69fb19ce5d730a70ab5d67272bb7202bd6c.tar.bz2
Making C profiling a configure option (at least temporarily)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 7e13874..c766eb1 100644
--- a/configure.in
+++ b/configure.in
@@ -1946,6 +1946,19 @@ then
fi
AC_MSG_RESULT($with_doc_strings)
+# Check for C call profiling support
+AC_MSG_CHECKING(for --with-c-profiling)
+AC_ARG_WITH(c-profiling,
+[ --with-c-profiling Enable profiling of builtins and C extension functions], [
+if test "$withval" != no
+then
+ AC_DEFINE(WITH_C_PROF, 1,
+ [Define to enable profile hooks for C extension functions and builtins])
+ AC_MSG_RESULT(yes)
+else AC_MSG_RESULT(no)
+fi],
+[AC_MSG_RESULT(no)])
+
# Check for Python-specific malloc support
AC_MSG_CHECKING(for --with-tsc)
AC_ARG_WITH(tsc,