summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJack Jansen <jack.jansen@cwi.nl>2001-10-31 12:11:48 (GMT)
committerJack Jansen <jack.jansen@cwi.nl>2001-10-31 12:11:48 (GMT)
commit666b1e7e2f929af06fdfd074304a727f3dc5ed12 (patch)
tree8878f4dc1eeb8500b1592949f7fe4e02f2fcc147 /configure.in
parentd17f4bd6c8bb2bed81695fb9ee13ccb0da930824 (diff)
downloadcpython-666b1e7e2f929af06fdfd074304a727f3dc5ed12.zip
cpython-666b1e7e2f929af06fdfd074304a727f3dc5ed12.tar.gz
cpython-666b1e7e2f929af06fdfd074304a727f3dc5ed12.tar.bz2
Link the core with CoreServices, not with Carbon, and don't use any Carbon
routines. As of 10.1 using Carbon will crash Python if no window server is available (ssh connection, console mode, MacOSX Server). This fixes bug #466907. A result of this mod is that the default 8bit encoding on OSX is now ASCII, for the time being. Also, the extension modules that need the Carbon framework now explicitly include it in setup.py.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index dd724ae..f90b692 100644
--- a/configure.in
+++ b/configure.in
@@ -655,7 +655,7 @@ then
fi
case "$enable_toolbox_glue" in
yes)
- extra_frameworks="-framework Carbon -framework Foundation"
+ extra_frameworks="-framework CoreServices -framework Foundation"
extra_machdep_objs="Python/mactoolboxglue.o"
extra_undefs="-u __dummy -u _PyMac_Error"
AC_DEFINE(USE_TOOLBOX_OBJECT_GLUE)