summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>1995-01-26 00:44:03 (GMT)
committerGuido van Rossum <guido@python.org>1995-01-26 00:44:03 (GMT)
commit71001e435521fbc67342d9f36fc2615b6c4db61b (patch)
tree5736d588f2c829419460c727694ed2fc160c46c3 /configure.in
parent0de81bfec9cda58648f0f085144a8e60b5f12b65 (diff)
downloadcpython-71001e435521fbc67342d9f36fc2615b6c4db61b.zip
cpython-71001e435521fbc67342d9f36fc2615b6c4db61b.tar.gz
cpython-71001e435521fbc67342d9f36fc2615b6c4db61b.tar.bz2
add OSF/1 LDSHARED; add IRIX5 conditional for sockets
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1f7e2a8..f471614 100644
--- a/configure.in
+++ b/configure.in
@@ -115,6 +115,7 @@ then
SunOS/4*) LDSHARED="ld";;
SunOS/5*) LDSHARED="ld -G";;
hp*|HP*) LDSHARED="ld -b";;
+ OSF*) LDSHARED="ld -shared -expect_unresolved \"*\"";;
DYNIX/ptx*) LDSHARED="ld -G";;
*) LDSHARED="ld";;
esac
@@ -145,9 +146,18 @@ AC_MSG_RESULT($LINKFORSHARED)
AC_CHECK_LIB(dl, dlopen) # Dynamic linking for SunOS/Solaris and SYSV
AC_CHECK_LIB(dld, shl_load) # Dynamic linking for HP-UX
AC_CHECK_LIB(sun, getpwnam) # NIS (== YP) interface for IRIX 4
+# The following three (nsl,inet,socket) are needed on Sequent;
+# the order of checking must be this. Most SVR4 platforms will
+# need -lsocket and -lnsl. However on SGI IRIX 5, these exist but
+# broken. I see no elegant solution (probably CHECK_LIB should be
+# fixed to only add the library if the given entry point is not
+# satisfied without it).
+if test "`uname -s`" != IRIX
+then
AC_CHECK_LIB(nsl, t_open, [LIBS="-lnsl $LIBS"]) # SVR4
AC_CHECK_LIB(inet, gethostbyname, [LIBS="-linet $LIBS"], [], -lnsl) # Sequent
AC_CHECK_LIB(socket, socket, [LIBS="-lsocket $LIBS"], [], $LIBS) # SVR4 sockets
+fi
AC_MSG_CHECKING(for --with-readline)
AC_ARG_WITH(readline, [--with-readline=DIRECTORY GNU readline], [