summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRonald Oussoren <ronaldoussoren@mac.com>2009-01-02 10:44:46 (GMT)
committerRonald Oussoren <ronaldoussoren@mac.com>2009-01-02 10:44:46 (GMT)
commit79f90498bc16172527615888e3cd622ccb2478af (patch)
tree06a71b0811413df65d69b5bacba4ff211c60e7e4 /configure.in
parent57eb0e90c12d5944602eb9944c963b31021481b5 (diff)
downloadcpython-79f90498bc16172527615888e3cd622ccb2478af.zip
cpython-79f90498bc16172527615888e3cd622ccb2478af.tar.gz
cpython-79f90498bc16172527615888e3cd622ccb2478af.tar.bz2
Fix for issue4472: "configure --enable-shared doesn't work on OSX"
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index a0768a5..ca504be 100644
--- a/configure.in
+++ b/configure.in
@@ -737,6 +737,12 @@ if test $enable_shared = "yes"; then
BLDLIBRARY='-L. -lpython$(VERSION)'
RUNSHARED=DLL_PATH=`pwd`:${DLL_PATH:-/atheos/sys/libs:/atheos/autolnk/lib}
;;
+ Darwin*)
+ LDLIBRARY='libpython$(VERSION).dylib'
+ BLDLIBRARY='-L. -lpython$(VERSION)'
+ RUNSHARED='DYLD_LIBRARY_PATH=`pwd`:${DYLD_LIBRARY_PATH}'
+ ;;
+
esac
else # shared is disabled
case $ac_sys_system in
@@ -1597,6 +1603,7 @@ else
sleep 10
fi
AC_MSG_RESULT($SO)
+
AC_DEFINE_UNQUOTED(SHLIB_EXT, "$SO", [Define this to be extension of shared libraries (including the dot!).])
# LDSHARED is the ld *command* used to create shared library
# -- "cc -G" on SunOS 5.x, "ld -shared" on IRIX 5