summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMark Hammond <mhammond@skippinet.com.au>2002-07-19 06:55:41 (GMT)
committerMark Hammond <mhammond@skippinet.com.au>2002-07-19 06:55:41 (GMT)
commit8235ea1c3a5c57c9279668b5bff3d5f021ceb2d5 (patch)
treeaaab09a7c61fc66bc25bb19cc885692bd0e8e121 /configure.in
parentb88169819c301dc77fc2f240c1641acf0b8cf5af (diff)
downloadcpython-8235ea1c3a5c57c9279668b5bff3d5f021ceb2d5.zip
cpython-8235ea1c3a5c57c9279668b5bff3d5f021ceb2d5.tar.gz
cpython-8235ea1c3a5c57c9279668b5bff3d5f021ceb2d5.tar.bz2
Land Patch [ 566100 ] Rationalize DL_IMPORT and DL_EXPORT.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 3b59383..3e2143b 100644
--- a/configure.in
+++ b/configure.in
@@ -125,8 +125,7 @@ AC_ARG_WITH(gcc, [ --without-gcc never use gcc], [
ppc)
CC=mwcc
without_gcc=yes
- OPT="-O -D'DL_EXPORT(RTYPE)=__declspec(dllexport) RTYPE' -D'DL_IMPORT(RTYPE)=__declspec(dllexport) RTYPE' -export pragma"
- CCSHARED="-UDL_IMPORT -D'DL_IMPORT(RTYPE)=__declspec(dllimport) RTYPE'"
+ OPT="-O -export pragma"
LDFLAGS="$LDFLAGS -nodup"
;;
x86)
@@ -359,6 +358,7 @@ fi
# Other platforms follow
if test $enable_shared = "yes"; then
+ AC_DEFINE(Py_ENABLE_SHARED, 1, [Defined if Python is built as a shared library.])
case $ac_sys_system in
BeOS*)
LDLIBRARY='libpython$(VERSION).so'
@@ -948,7 +948,6 @@ then
*gcc*) CCSHARED="-shared";;
*) CCSHARED="";;
esac;;
- CYGWIN*) CCSHARED="-DUSE_DL_IMPORT";;
atheos*) CCSHARED="-fPIC";;
esac
fi