summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRonald Oussoren <ronaldoussoren@mac.com>2009-09-08 07:13:53 (GMT)
committerRonald Oussoren <ronaldoussoren@mac.com>2009-09-08 07:13:53 (GMT)
commit856624d449ee7912f512142039ff42dba1188988 (patch)
tree46f5adc54d681aaeb605fd4745830538dfe90c58 /configure.in
parentda76ba9459d0f5cd2ff112a6b8c1715d5af1f9e5 (diff)
downloadcpython-856624d449ee7912f512142039ff42dba1188988.zip
cpython-856624d449ee7912f512142039ff42dba1188988.tar.gz
cpython-856624d449ee7912f512142039ff42dba1188988.tar.bz2
Merged revisions 74713 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/branches/py3k ................ r74713 | ronald.oussoren | 2009-09-08 09:12:42 +0200 (Tue, 08 Sep 2009) | 9 lines Merged revisions 74701 via svnmerge from svn+ssh://pythondev@svn.python.org/python/trunk ........ r74701 | ronald.oussoren | 2009-09-07 08:12:00 +0200 (Mon, 07 Sep 2009) | 2 lines Fix typo in configure.in ........ ................
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in26
1 files changed, 22 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index b7b6a98..392ac0d 100644
--- a/configure.in
+++ b/configure.in
@@ -106,7 +106,7 @@ AC_SUBST(ARCH_RUN_32BIT)
UNIVERSAL_ARCHS="32-bit"
AC_MSG_CHECKING(for --with-universal-archs)
AC_ARG_WITH(universal-archs,
- AC_HELP_STRING(--with-universal-archs=ARCH, select architectures for universal build ("32-bit", "64-bit" or "all")),
+ AC_HELP_STRING(--with-universal-archs=ARCH, select architectures for universal build ("32-bit", "64-bit", "3-way", "intel" or "all")),
[
AC_MSG_RESULT($withval)
UNIVERSAL_ARCHS="$withval"
@@ -916,6 +916,14 @@ yes)
UNIVERSAL_ARCH_FLAGS="-arch i386 -arch ppc -arch ppc64 -arch x86_64"
ARCH_RUN_32BIT="arch -i386 -ppc"
+ elif test "$UNIVERSAL_ARCHS" = "intel" ; then
+ UNIVERSAL_ARCH_FLAGS="-arch i386 -arch x86_64"
+ ARCH_RUN_32BIT="arch -i386"
+
+ elif test "$UNIVERSAL_ARCHS" = "3-way" ; then
+ UNIVERSAL_ARCH_FLAGS="-arch i386 -arch ppc -arch x86_64"
+ ARCH_RUN_32BIT="arch -i386 -ppc"
+
else
AC_MSG_ERROR([proper usage is --with-universalarch=32-bit|64-bit|all])
@@ -941,6 +949,15 @@ yes)
# that's the first OS release where
# 4-way builds make sense.
cur_target='10.5'
+
+ elif test "${UNIVERSAL_ARCHS}" = "3-way"; then
+ cur_target='10.5'
+
+ elif test "${UNIVERSAL_ARCHS}" = "intel"; then
+ cur_target='10.5'
+
+ elif test "${UNIVERSAL_ARCHS}" = "64-bit"; then
+ cur_target='10.5'
fi
else
if test `arch` = "i386"; then
@@ -1519,7 +1536,7 @@ case $ac_sys_system/$ac_sys_release in
else
LIBTOOL_CRUFT=""
fi
- AC_TRY_RUN([[
+ AC_TRY_RUN([
#include <unistd.h>
int main(int argc, char*argv[])
{
@@ -1528,9 +1545,10 @@ case $ac_sys_system/$ac_sys_release in
} else {
return 1;
}
- ]], ac_osx_32bit=yes,
+ }
+ ], ac_osx_32bit=yes,
ac_osx_32bit=no,
- ac_osx_32bit=no)
+ ac_osx_32bit=yes)
if test "${ac_osx_32bit}" = "yes"; then
case `arch` in