summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlexandre Vassalotti <alexandre@peadrop.com>2009-07-17 04:59:05 (GMT)
committerAlexandre Vassalotti <alexandre@peadrop.com>2009-07-17 04:59:05 (GMT)
commit856782e45e700ad0ff48341460200eb87dad0122 (patch)
tree6fd253bd00d4e4b587e89d3e1e1db3aea6d2cbc9 /configure.in
parent786c29e39ed5eea267e7a4708f402812f8df52ef (diff)
downloadcpython-856782e45e700ad0ff48341460200eb87dad0122.zip
cpython-856782e45e700ad0ff48341460200eb87dad0122.tar.gz
cpython-856782e45e700ad0ff48341460200eb87dad0122.tar.bz2
Rename the useless AC_INCLUDES_DEFAULT and protect the includes.
This is mostly an aesthetic change.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 15 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 681757d..0e193a2 100644
--- a/configure.in
+++ b/configure.in
@@ -1428,9 +1428,10 @@ AC_CHECK_TYPES(uintptr_t,
#include <stdint.h>
#endif])
-AC_CHECK_SIZEOF(off_t, []
-[AC_INCLUDES_DEFAULT,
- #include <sys/types.h>
+AC_CHECK_SIZEOF(off_t, [], [
+#ifdef HAVE_SYS_TYPES_H
+#include <sys/types.h>
+#endif
])
AC_MSG_CHECKING(whether to enable large file support)
@@ -1447,9 +1448,13 @@ else
AC_MSG_RESULT(no)
fi
-AC_CHECK_SIZEOF(time_t, []
-[AC_INCLUDES_DEFAULT,
- #include <time.h>
+AC_CHECK_SIZEOF(time_t, [], [
+#ifdef HAVE_SYS_TYPES_H
+#include <sys/types.h>
+#endif
+#ifdef HAVE_TIME_H
+#include <time.h>
+#endif
])
# if have pthread_t then define SIZEOF_PTHREAD_T
@@ -1466,9 +1471,10 @@ have_pthread_t=no
AC_TRY_COMPILE([#include <pthread.h>], [pthread_t x; x = *(pthread_t*)0;], have_pthread_t=yes)
AC_MSG_RESULT($have_pthread_t)
if test "$have_pthread_t" = yes ; then
- AC_CHECK_SIZEOF(pthread_t, []
- [AC_INCLUDES_DEFAULT,
- #include <pthread.h>
+ AC_CHECK_SIZEOF(pthread_t, [], [
+#ifdef HAVE_PTHREAD_H
+#include <pthread.h>
+#endif
])
fi
CC="$ac_save_cc"