summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRonald Oussoren <ronaldoussoren@mac.com>2009-06-08 21:22:57 (GMT)
committerRonald Oussoren <ronaldoussoren@mac.com>2009-06-08 21:22:57 (GMT)
commit99aab651136f1101e278edda8b751b5f8e9f2cac (patch)
tree480e3cf231e30004aad79e5b0aa2806cbd624141 /configure.in
parent0d2cceb01ca2d285aafcf92ad6a9dfcc61f4d722 (diff)
downloadcpython-99aab651136f1101e278edda8b751b5f8e9f2cac.zip
cpython-99aab651136f1101e278edda8b751b5f8e9f2cac.tar.gz
cpython-99aab651136f1101e278edda8b751b5f8e9f2cac.tar.bz2
Merged revisions 73305 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk ........ r73305 | ronald.oussoren | 2009-06-08 14:12:41 -0700 (Mon, 08 Jun 2009) | 4 lines This is a fix for Issue5809: you shouldn't specify both --enable-framework and --enable-shared ........
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 73472bd..ecd789a 100644
--- a/configure.in
+++ b/configure.in
@@ -1522,6 +1522,10 @@ then
[Define if you want to produce an OpenStep/Rhapsody framework
(shared library plus accessory files).])
AC_MSG_RESULT(yes)
+ if test $enable_shared = "yes"
+ then
+ AC_MSG_ERROR([Specifying both --enable-shared and --enable-framework is not supported, use only --enable-framework instead])
+ fi
else
AC_MSG_RESULT(no)
fi