summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>1995-02-13 19:45:27 (GMT)
committerGuido van Rossum <guido@python.org>1995-02-13 19:45:27 (GMT)
commitaf07a4442817d28e8733703190aeb54e7da3238f (patch)
tree98dc8a211f2b8d4a679314aa2e37ae2ad226c420 /configure.in
parent57c33af90e815c311bc6e70a49f3d540f12fda3a (diff)
downloadcpython-af07a4442817d28e8733703190aeb54e7da3238f.zip
cpython-af07a4442817d28e8733703190aeb54e7da3238f.tar.gz
cpython-af07a4442817d28e8733703190aeb54e7da3238f.tar.bz2
the usual
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index f471614..0ef0473 100644
--- a/configure.in
+++ b/configure.in
@@ -50,7 +50,8 @@ AC_TRY_RUN([
#ifdef _NEXT_SOURCE
main() { exit(0); }
#endif
-], AC_DEFINE(_POSIX_SOURCE) was_it_defined=yes)
+], AC_DEFINE(_POSIX_SOURCE)
+CC="$CC -posix"; was_it_defined=yes)
AC_MSG_CHECKING(for NeXT)
AC_MSG_RESULT($was_it_defined)
@@ -127,7 +128,10 @@ AC_MSG_CHECKING(CCSHARED)
if test -z "$CCSHARED"
then
case $ac_sys_system in
- hp*|HP*) CCSHARED="+z";;
+ hp*|HP*) if test "$GCC" = yes;
+ then CCSHARED="-fpic";
+ else CCSHARED="+z";
+ fi;;
esac
fi
AC_MSG_RESULT($CCSHARED)