summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>1995-01-04 19:02:35 (GMT)
committerGuido van Rossum <guido@python.org>1995-01-04 19:02:35 (GMT)
commitaf5b83ec4afa74b3bd1b0750f14fc24bf111c059 (patch)
treeef01fc5ec84c6367bce70ba0c853014167b69f58 /configure.in
parentefc8713428b1f132c7d4bdf849593eb3684e7586 (diff)
downloadcpython-af5b83ec4afa74b3bd1b0750f14fc24bf111c059.zip
cpython-af5b83ec4afa74b3bd1b0750f14fc24bf111c059.tar.gz
cpython-af5b83ec4afa74b3bd1b0750f14fc24bf111c059.tar.bz2
README: changed URL format to <URL:...>; added section on Tk.
Makefile.in: run config.status in "make recheck". configure.in: add test for hypot(). config.h.in, configure: since configure.in changed. rest: the usual boring stuff.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index ae7431d..34af46f 100644
--- a/configure.in
+++ b/configure.in
@@ -295,5 +295,11 @@ then LIBC=$withval
else AC_ERROR(proper usage is --with-libc=STRING)
fi])
+# check for hypot() in math library
+LIBS_SAVE=$LIBS
+LIBS="$LIBS $LIBM"
+AC_CHECK_FUNCS(hypot)
+LIBS=$LIBS_SAVE
+
# generate output files
AC_OUTPUT(Makefile Objects/Makefile Parser/Makefile Python/Makefile Modules/Makefile.pre)