summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMatthias Klose <doko@ubuntu.com>2010-04-25 21:18:48 (GMT)
committerMatthias Klose <doko@ubuntu.com>2010-04-25 21:18:48 (GMT)
commitbada4c39a12c8cd75c5270a53b090a8bdef867ac (patch)
tree8890157db4acc4369a35cb4590612ab0922c98fa /configure.in
parent44d3d7854b2c074f80bfee2e9523f246cf850bba (diff)
downloadcpython-bada4c39a12c8cd75c5270a53b090a8bdef867ac.zip
cpython-bada4c39a12c8cd75c5270a53b090a8bdef867ac.tar.gz
cpython-bada4c39a12c8cd75c5270a53b090a8bdef867ac.tar.bz2
configure.in: Avoid autoconf warning: Assume C89 semantics that
RETSIGTYPE is always void (issue #8510).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 1 insertions, 12 deletions
diff --git a/configure.in b/configure.in
index 0f0b37a..7d3c573 100644
--- a/configure.in
+++ b/configure.in
@@ -1374,18 +1374,7 @@ EOF
AC_TYPE_MODE_T
AC_TYPE_OFF_T
AC_TYPE_PID_T
-AC_DIAGNOSE([obsolete],[your code may safely assume C89 semantics that RETSIGTYPE is void.
-Remove this warning and the `AC_CACHE_CHECK' when you adjust the code.])dnl
-AC_CACHE_CHECK([return type of signal handlers],[ac_cv_type_signal],[AC_COMPILE_IFELSE(
-[AC_LANG_PROGRAM([#include <sys/types.h>
-#include <signal.h>
-],
- [return *(signal (0, 0)) (0) == 1;])],
- [ac_cv_type_signal=int],
- [ac_cv_type_signal=void])])
-AC_DEFINE_UNQUOTED([RETSIGTYPE],[$ac_cv_type_signal],[Define as the return type of signal handlers
- (`int' or `void').])
-
+AC_DEFINE_UNQUOTED([RETSIGTYPE],[void],[assume C89 semantics that RETSIGTYPE is always void])
AC_TYPE_SIZE_T
AC_TYPE_UID_T
AC_TYPE_UINT32_T