summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRonald Oussoren <ronaldoussoren@mac.com>2010-02-11 13:24:45 (GMT)
committerRonald Oussoren <ronaldoussoren@mac.com>2010-02-11 13:24:45 (GMT)
commitc8c89c4e6292df2ed1c269f51e7dc51b380f9e5b (patch)
tree3d9b3766fe87e7dfa6115792f8efeede1c2fa209 /configure.in
parent733ecdcc2f88a4231853c364aacb702b7a6949f9 (diff)
downloadcpython-c8c89c4e6292df2ed1c269f51e7dc51b380f9e5b.zip
cpython-c8c89c4e6292df2ed1c269f51e7dc51b380f9e5b.tar.gz
cpython-c8c89c4e6292df2ed1c269f51e7dc51b380f9e5b.tar.bz2
Merged revisions 78152 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/branches/py3k ........ r78152 | ronald.oussoren | 2010-02-11 14:23:08 +0100 (Thu, 11 Feb 2010) | 4 lines Fix for issue #7715: explicitly use the system arch instead of whatever is on the user's path. This is needed because GNU arch is not necessarily compatible with Apple's version. ........
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 8b03217..85c065f 100644
--- a/configure.in
+++ b/configure.in
@@ -912,15 +912,15 @@ yes)
elif test "$UNIVERSAL_ARCHS" = "all" ; then
UNIVERSAL_ARCH_FLAGS="-arch i386 -arch ppc -arch ppc64 -arch x86_64"
- ARCH_RUN_32BIT="arch -i386 -ppc"
+ ARCH_RUN_32BIT="/usr/bin/arch -i386 -ppc"
elif test "$UNIVERSAL_ARCHS" = "intel" ; then
UNIVERSAL_ARCH_FLAGS="-arch i386 -arch x86_64"
- ARCH_RUN_32BIT="arch -i386"
+ ARCH_RUN_32BIT="/usr/bin/arch -i386"
elif test "$UNIVERSAL_ARCHS" = "3-way" ; then
UNIVERSAL_ARCH_FLAGS="-arch i386 -arch ppc -arch x86_64"
- ARCH_RUN_32BIT="arch -i386 -ppc"
+ ARCH_RUN_32BIT="/usr/bin/arch -i386 -ppc"
else
AC_MSG_ERROR([proper usage is --with-universal-arch=32-bit|64-bit|all|intel|3-way])