summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorFred Drake <fdrake@acm.org>2000-07-09 14:39:29 (GMT)
committerFred Drake <fdrake@acm.org>2000-07-09 14:39:29 (GMT)
commitce81d59c0cb1be048c279f0acf5205da77a82e23 (patch)
tree74d8203c4609e866336696f895f39a8a9fe906bc /configure.in
parent3cd2ee4037156e5aab352a75b1e879f47808b468 (diff)
downloadcpython-ce81d59c0cb1be048c279f0acf5205da77a82e23.zip
cpython-ce81d59c0cb1be048c279f0acf5205da77a82e23.tar.gz
cpython-ce81d59c0cb1be048c279f0acf5205da77a82e23.tar.bz2
Remove setup of HAVE_OLD_CPP; it is no longer used in the Python sources.
The actual test for it is only commented out in configure.in, so it can be re-enabled if we ever run across the need for it again.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 0f9452f..46dd5f1 100644
--- a/configure.in
+++ b/configure.in
@@ -342,14 +342,14 @@ else
fi
fi
-# check for ANSI or K&R ("traditional") preprocessor
-AC_MSG_CHECKING(for C preprocessor type)
-AC_TRY_COMPILE([
-#define spam(name, doc) {#name, &name, #name "() -- " doc}
-int foo;
-struct {char *name; int *addr; char *doc;} desc = spam(foo, "something");
-], [;], cpp_type=ansi, AC_DEFINE(HAVE_OLD_CPP) cpp_type=traditional)
-AC_MSG_RESULT($cpp_type)
+dnl # check for ANSI or K&R ("traditional") preprocessor
+dnl AC_MSG_CHECKING(for C preprocessor type)
+dnl AC_TRY_COMPILE([
+dnl #define spam(name, doc) {#name, &name, #name "() -- " doc}
+dnl int foo;
+dnl struct {char *name; int *addr; char *doc;} desc = spam(foo, "something");
+dnl ], [;], cpp_type=ansi, AC_DEFINE(HAVE_OLD_CPP) cpp_type=traditional)
+dnl AC_MSG_RESULT($cpp_type)
# checks for header files
AC_HEADER_STDC