summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJeffrey Yasskin <jyasskin@gmail.com>2010-07-09 16:30:58 (GMT)
committerJeffrey Yasskin <jyasskin@gmail.com>2010-07-09 16:30:58 (GMT)
commitd4fcdb1ea847389f0cc62840d59d0701f33bbf3d (patch)
tree4aa78e816c9dd0575f1f9aec33eeb4e36c3c571b /configure.in
parent74e4561a3cdf9d38caca4573b68e1c72fc489629 (diff)
downloadcpython-d4fcdb1ea847389f0cc62840d59d0701f33bbf3d.zip
cpython-d4fcdb1ea847389f0cc62840d59d0701f33bbf3d.tar.gz
cpython-d4fcdb1ea847389f0cc62840d59d0701f33bbf3d.tar.bz2
Issue #9189: Allow users to set $CFLAGS, $CPPFLAGS, and $LDFLAGS when running
configure to append to Python's default values for those variables, and similarly allow users to set $XXFLAGS on the make command line to append to the values set by configure. In the makefile, this renames the variables that used to be $XXFLAGS to $PY_XXFLAGS, and renames the old $PY_CFLAGS to $PY_CORE_CFLAGS. To compensate, sysconfig now aliases $XXFLAGS=$PY_XXFLAGS so that scripts using it keep working. I see that as the right interface, not a backward-compatibility hack, since these are logically the $XXFLAGS variables; we just use a different name in the makefile to deal with make's semantics.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 6 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index b3d5158..4a7e99a 100644
--- a/configure.in
+++ b/configure.in
@@ -461,14 +461,13 @@ then
(it is also a good idea to do 'make clean' before compiling)])
fi
-# If the user set CFLAGS, use this instead of the automatically
-# determined setting
-preset_cflags="$CFLAGS"
-AC_PROG_CC
-if test ! -z "$preset_cflags"
-then
- CFLAGS=$preset_cflags
+# Don't let AC_PROG_CC set the default CFLAGS. It normally sets -g -O2
+# when the compiler supports them, but we don't always want -O2, and
+# we set -g later.
+if test -z "$CFLAGS"; then
+ CFLAGS=
fi
+AC_PROG_CC
AC_SUBST(CXX)
AC_SUBST(MAINCC)