summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2003-03-30 17:23:49 (GMT)
committerMartin v. Löwis <martin@v.loewis.de>2003-03-30 17:23:49 (GMT)
commitf26d63b3e19bf57e93010ec4a0a5af1a87e3bcef (patch)
tree574b19e53c61179b25770b35107ba34162198982 /configure.in
parent852ba7eb2a38a4d57cea73bf34b11f8e65f004e1 (diff)
downloadcpython-f26d63b3e19bf57e93010ec4a0a5af1a87e3bcef.zip
cpython-f26d63b3e19bf57e93010ec4a0a5af1a87e3bcef.tar.gz
cpython-f26d63b3e19bf57e93010ec4a0a5af1a87e3bcef.tar.bz2
Patch #650412: Check whether the address of flock and getpagesize
can be taken, and use _SC_PAGE_SIZE if getpagesize is not available.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 21 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 4378838..5f455c1 100644
--- a/configure.in
+++ b/configure.in
@@ -1849,7 +1849,7 @@ AC_MSG_RESULT(MACHDEP_OBJS)
# checks for library functions
AC_CHECK_FUNCS(alarm chown clock confstr ctermid execv \
- fchdir flock fork fsync fdatasync fpathconf ftime ftruncate \
+ fchdir fork fsync fdatasync fpathconf ftime ftruncate \
gai_strerror getgroups getlogin getloadavg getpeername getpgid getpid \
getpriority getpwent getwd \
hstrerror inet_aton inet_pton kill killpg lchown lstat mkfifo mknod mktime \
@@ -1898,6 +1898,26 @@ AC_TRY_COMPILE([
AC_MSG_RESULT(no)
)
+AC_MSG_CHECKING(for flock)
+AC_TRY_COMPILE([
+#include "confdefs.h"
+#include <sys/file.h>
+], void* p = flock,
+ AC_DEFINE(HAVE_FLOCK, 1, Define if you have the 'flock' function.)
+ AC_MSG_RESULT(yes),
+ AC_MSG_RESULT(no)
+)
+
+AC_MSG_CHECKING(for getpagesize)
+AC_TRY_COMPILE([
+#include "confdefs.h"
+#include <unistd.h>
+], void* p = getpagesize,
+ AC_DEFINE(HAVE_GETPAGESIZE, 1, Define if you have the 'getpagesize' function.)
+ AC_MSG_RESULT(yes),
+ AC_MSG_RESULT(no)
+)
+
AC_MSG_CHECKING(for setgroups)
AC_TRY_COMPILE([
#include "confdefs.h"