summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBarry Warsaw <barry@python.org>2010-10-18 17:09:07 (GMT)
committerBarry Warsaw <barry@python.org>2010-10-18 17:09:07 (GMT)
commitf040d7de94a057f2c26c8b3d140b33273bfcc595 (patch)
tree32e2828b339c11ee35de02631de9353e5d4be2dc /configure.in
parenteebccfb10c423a3f10af8f2bdd0a44cd7e588f37 (diff)
downloadcpython-f040d7de94a057f2c26c8b3d140b33273bfcc595.zip
cpython-f040d7de94a057f2c26c8b3d140b33273bfcc595.tar.gz
cpython-f040d7de94a057f2c26c8b3d140b33273bfcc595.tar.bz2
One more change for issue 9807, by Matthias Klose.
This adds $ABIFLAGS to the static library, since it should match the shared library name. Also, include the abiflags in python-config --libs.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 9585b09..2610657 100644
--- a/configure.in
+++ b/configure.in
@@ -585,7 +585,7 @@ AC_SUBST(LIBRARY)
AC_MSG_CHECKING(LIBRARY)
if test -z "$LIBRARY"
then
- LIBRARY='libpython$(VERSION).a'
+ LIBRARY='libpython$(VERSION)$(ABIFLAGS).a'
fi
AC_MSG_RESULT($LIBRARY)