summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>1995-09-13 17:48:09 (GMT)
committerGuido van Rossum <guido@python.org>1995-09-13 17:48:09 (GMT)
commit55a214e39d7f92bf5ca226148325408f55eb9885 (patch)
tree87975cc39d2f05e44bea0ed84e1e65e7dba2204a /configure.in
parentbbc3410fa819ff3b0945d9cf9fcb92550b0b799a (diff)
downloadcpython-55a214e39d7f92bf5ca226148325408f55eb9885.zip
cpython-55a214e39d7f92bf5ca226148325408f55eb9885.tar.gz
cpython-55a214e39d7f92bf5ca226148325408f55eb9885.tar.bz2
on osf/1, never use gcc; added test for strftime()
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 67d4cba..0ac4c80 100644
--- a/configure.in
+++ b/configure.in
@@ -14,7 +14,12 @@ AC_ARG_WITH(gcc, [--without-gcc never use gcc], [
without_gcc=no;;
*) CC=$withval
without_gcc=$withval;;
- esac], [without_gcc=no])
+ esac], [
+ case `uname -s` in
+ OSF1) CC=cc
+ without_gcc=;;
+ *) without_gcc=no;;
+ esac])
AC_MSG_RESULT($without_gcc)
# If the user switches compilers, we can't believe the cache
@@ -234,7 +239,7 @@ DLINCLDIR=${dldir}
LIBS="$LIBS -ldl -ldld"], AC_MSG_RESULT(no))
# checks for library functions
-AC_CHECK_FUNCS(chown clock dlopen ftime ftruncate gethostname_r gettimeofday getpeername getpgrp getpid getwd link lstat nice readlink select setgid setuid setsid setpgid setpgrp setvbuf siginterrupt symlink tcgetpgrp tcsetpgrp times truncate uname waitpid)
+AC_CHECK_FUNCS(chown clock dlopen ftime ftruncate gethostname_r gettimeofday getpeername getpgrp getpid getwd link lstat nice readlink select setgid setuid setsid setpgid setpgrp setvbuf siginterrupt strftime symlink tcgetpgrp tcsetpgrp times truncate uname waitpid)
AC_REPLACE_FUNCS(dup2 getcwd strerror memmove)
AC_CHECK_FUNC(getpgrp, AC_TRY_COMPILE([#include <unistd.h>], [getpgrp(0);], AC_DEFINE(GETPGRP_HAVE_ARG)))
AC_CHECK_FUNC(setpgrp, AC_TRY_COMPILE([#include <unistd.h>], [setpgrp(0,0);], AC_DEFINE(SETPGRP_HAVE_ARG)))